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Download and Installation of Afinion Project-Viewer

Introduction
The download for Afinion Project-Viewer (APV) is available from one of our 
homepages www.afinion.com, www.afinion.de, www.afinion.ch, the homepages of 
our distributors and several shareware sites.

You can find more detailed information on the APV in subdirectory: PM Software → 
MS Project → Afinion Project-Viewer → Afinion Project-Viewer. APV is a Java-
Application. It is therefore possible to use APV with Windows, Mac (OS/X), SUN 
(Solaris) and Linux operation systems. The functions “export assignments / 
appointments to Outlook” and “create a connection to a MS Access database” are 
available with Windows only.

Note:
Please read the installation guide on our homepage if you would like to display SAP 
PS plans too.

Download and Installation (Windows)
• Save the file  project-viewer_xxx.exe in a folder of your choice, where xxx = 

free, light, full.
• Start the file project-viewer_xxx.exe by double-click.
• In the following window enter the location where you want to install Afinion 

Project-Viewer. The default path is “ C:\Program Files\ProjectViewer”. Click on 
the button “Durchsuchen…” to change the path. Then click on the button 
“Installieren >” to proceed with the installation.

The installation process will now start, showing the files being copied.

http://www.Afinion.ch/
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The following wizard will guide you through the basic configuration of Afinion Project-
Viewer. 

• Select your preferred language and then click on “Next >”.

• Activate this option to automatically open .mpp files with APV.
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• Activate  these  options  to  create  shortcuts  for  the  application  in  the  Start 
menu, on the Desktop and/or in the Quick Launch toolbar.

• Click on “Close” to complete the installation.

If you already have received your license file (license.xml), copy it into the folder 
“PViewer” inside the Project-Viewer installation folder 
(Default:C\Program files\ProjectViewer\PViewer). 
Make sure to keep a backup of the license file since you will need to reinstall it after 
having reinstalled or upgraded the application.

After finishing the installation you can start the Afinion Project-Viewer using one of the 
shortcuts.

Download and Installation (Unix, Linux, Mac OS X)
• Save the file project-viewer_xxx.zip, where xxx = free, light or full, in a directory 

of your choice. Extract the archive to a new folder in your program directory.
• If you have not already installed Java runtime 1.4 or later, download it from 

http://wwws.sun.com/software/download.
• Start  APV by double-clicking the file  “ProjectViewer.jar”  in  a file  manager, 

finder, …

If your configuration does not support this way, APV can be started as follows:

1. The environmental variable JAVA_HOME must point to your Java installation

2. Then start APV with the command “java –jar ProjectViewer.jar”

Setup of File Types and File Access

Afinion Project-Viewer with .mpp
You can link to an .mpp plan directly:

• Go to menu File > Open and select the .mpp file
Alternatively

• Go to menu File > Open Project

http://wwws.sun.com/software/download
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Afinion Project-Viewer with Microsoft Access
If  you are using projects  in  Microsoft  Access  formats,  ending with either  .mpd or 
.mdb, proceed as follows:.

• Go to menu File > Connection Manager
• Click on register “MS Access”
• Click on “New”

• Press the button  .  Now an explorer window is opened where you can 
select the desired database.

In  order  to  ascertain  that  the  link  to  the  database  works  press  the  button 
. When you get the message “link checked – version available” you can 

save the test connection by pressing “Save”. Then press “Connect”, to create a link 
to your database.

Note:
At this  point  of  time “only” the link to the database was established, so that it 
doesn’t have to be recreated every time you want to open the project. This link has 
no effect on the content of your database.

A new window is displayed, in which your link is shown.
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This  example is  named “Engineering”.  Click  on  the project  and press  the button 
“Load”. If you (as shown in this example) have chosen not to select any resources, 
the whole content of the project will be displayed. Alternatively you can pre-select a 
single resource so that only the activities to which that resource is assigned is shown.
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Display of the complete database:

Afinion Project-Viewer with Microsoft SQL –Server
If  you  want  to  establish  a  link  to  an  SQL  database,  please  refer  to  your  system 
administrator for him to make the appropriate settings. Depending on the structure 
of your EDP-System, you may require settings that cannot be provided by the Project-
Viewer.

Start the Connection Manager, press “New” and then select the register “MSSQL-
Server”.
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By clicking on the button   you or  your  EDP administrator  can enter  the 
necessary information, such as specific settings for the company and passwords. You 
can test the connection by pressing the button  .  If  the connection is 
created press “Save”. The connection  is saved immediately. As soon as the link is 
created and saved you can load the database.

Afinion Project-Viewer with DSN Connection
If you want to create a link to a database over a DSN connection, please refer to 
your system administrator for the relevant settings. As stated above we cannot 
provide you with the specifications of your company.

By clicking on the button   you or  your  EDP administrator  can enter  the 
necessary information, such as specific settings for the company and passwords. You 
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can test the connection by pressing the button  .  If  the connection is 
created press “Save”. The connection  is saved immediately. As soon as the link is 
created and saved you can load the database.

Afinion Project-Viewer and SAP PS
Important:
There is no installation of SAP GUI required to run the Project-Viewer. 

If you do have installed the SAP GUI, please consider the following:
The Afinion Project-Viewer  requires  the file  LibRfc32.dll  Version 6206.6.1456.4314 or 
higher.
This file must be copied into the directory Windows\system32.
You  will  find  the  file  in  Afinion  Project-Viewer  installation  directory.  The  default 
directory is:

 C:\Program Files\AfinionViewer\PViewer.

You can also download the file from SAP directly from  
http://service.sap.com/connectors  
Go to SAP Java Connectors\Tools & Services | Download SAP JCo Release 2.1.3 | 
Windows 2000,… - 32 bit SAP JCo 2.1.3 and download it as zip file.

After  copying  the  file  into  your  Windows\system32  directory,  you  can  create  a 
connection to your SAP Server. 

The Connection Manager offers the possibility to access a database of your choice. 
If  you  would  like  to  access  another  database,  you  have  to  establish  a  new 
connection with the Connection Manager.

To  check  if  the  connection  to  the  database  is  functioning,  press  the  button 
 first.  If you receive the message “Connection tested”, you can save 

your test-connection for the time being. Then press the button “Connect” to establish 
a connection to the database.

http://service.sap.com/connectors 
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Click on one of the four radio buttons on top of the window to choose which data 
shall be displayed. On the left hand side of the window you have the opportunity to 
select a project definition (unless the radio button “network plan” was checked). On 
the right hand side of the window you can choose a single network plan (only if the 
radio button “network plan” is checked). Then press “Open”.

The Connection Wizard

By  clicking  the  button   you  or  your  EDP  administrator  can  enter  the 
necessary settings. In this window you can select the type of link you want to create. 

After pressing the button “Next” a new window is opened. There you can enter the 
details for path, server name, server database, login and password. In case these 
details are not available to you, please refer to your system administrator.
After pressing the button “Test” your link will be tested and the result will be displayed 
in a message box. By pressing the button “Finish” the link will be finally created and 
saved.
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Working with Afinion Project-Viewer

General 

The APV shows you the activities of the project on the left hand side and a bar chart 
(Gantt) on the right hand side. Vertical red lines indicate the start and the end of the 
project. Actual project, resource (in case you have chosen one) and actual date 
are displayed in the title bar.
In the task bar on the left you can choose different Gantt Charts and Views used by 
the project manager in Microsoft Project. The view “My View” is a standard view in 
which the user has the possibility to create and save an individual view (see page 
below).

The menu bar contains five menus:

1. File: Click on „Open” to directly open an existing .mpp file. An explorer 
window to choose your file will be opened.
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The  subsidiary  point  “Connection  Manager”  opens  the 
Connection Manager. Use the Connection Manager as described 
above.

The  subsidiary  point  „Load  Project  from  .mpp  File“  opens  a 
window displaying the actual connection to a database. In that 
window  you  can  choose  a  different  project  from  the  actual 
database.

Click „Exit“ to close APV.

2. Language: In the language menu, you have the alternatives German, English, 
Italian or Dutch.

3. View: In  the  menu  „View“  you  you  can  enlarge  or  reduce the  time 
scale.

Additionally you have the alternative to enlarge or to reduce the 
display.

The subsidiary “Print” opens a window with print settings. More on 
printing will be explained later.

By clicking on the „Expand Node” or the “Collapse Node“, you 
can  choose  between  partial  display  and  full  display  of  the 
activities.

“Enable / Disable Links” displays the connections in the bar chart.

“Fit  in  Window”  scales  the  view,  so  that  the  whole  project  is 
displayed in the bar chart.

“Adjust Columns“ opens a window to show or hide the columns 
individually  in  the  view  “Meine  Ansicht”.  To  get  an  exact 
description of your alternatives please refer to chapter xxx .

4. Admin: Please choose between Client - or Server version 

5. Information: Contact – and license information
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Resource Controlled Display
When starting Afinion Project-Viewer you have the possibility to display a dedicated 
or assigned resource only. Available resources are shown in a Pull-Down menu.
If  there  are  several  projects  in  the  database,  all  activities  of  one  resource  in  all 
projects may be viewed.

In addition, there is the possibility to choose the resources in a loaded plan.
After doing so, the displayed information is  refreshed, and all  the activities of the 
chosen resource are shown.
E.g.  in  the  case  of  ‘vacation  replacement’  the  display  can  be  set  to  show the 
activities  of  a  colleague  (resource)  and  the  assignment  being  viewed  can  be 
exported to Outlook. More on this will be explained later.

The Toolbar of Afinion Project-Viewer

The icons have the following functionality:

Opens the explorer window to select and open an .mpp file

Opens the window with your actual database connection to choose a 
different project

Opens the Connection Manager

Sets the time scale in the bar chart
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Sets the unit width in the bar chart

Magnifying button to enlarge the time scale 

Magnifying button to reduce the time scale

Magnifying button to enlarge the table display

Magnifying button to reduce the table display

Print. Page preview and setup (see chapter )

Exports assignment and appointments to outlook

Expands tree

Collapses tree

Shows connections in the bar chart

Hides connections in the bar chart

Fits the bar chart in order to display the entire project

Displays contact information

License agreement

All icons are displayed with tool tips, which will provide additional information when 
the mouse is moved over the selected icon.

Change / Adjust Table View, Insert Additional Columns

„View“ →„Adjust Columns“ opens the window „Table definition for ‘My View’“. Here 
you can create and save an individual table view called “My View”. 
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The buttons of „Table definition of ‘My View’“

Insert before: Inserts a new column before the marked column
Insert after: Inserts a new column after the marked column
Delete: Deletes the marked column
Move up: Moves the column one position upwards
Move down: Moves one position downwards
Save: Saves changed settings
Cancel: Closes the window without saving settings

In addition to that,  you can display columns used by the project manager in MS 
Project or SAP PS. If for example the column “Text1” exists in the original file, you can 
add it by inserting „Text1“ in “Name”. The content of the original column will now be 
shown in APV.
You have to distinguish between „Name“ and „Title“. The title of the original column 
will not be adopted. One can choose an individual title in APV.
After changing the table view, click on “Save” to adopt the settings.

Change / Adjust the Table View
If you press the left mouse button in the head area of the columns, you can move 
the  selected  column.  This  allows  you  to  order  the  columns  according  to  your 
requirements and priorities. In order to increase or decrease the width of the rows, 
click  on the border  of  the row-header  and move it  to  the right  or  the left  while 
keeping the mouse button pressed, exactly as it is done in Excel.
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Enlarge / Reduce the Bar Chart (Gantt)

If you want to enlarge or reduce the bar chart press one of the black arrows on top 
of the bar between bar chart and table pointing left or right. Alternatively you can 
move the bar by clicking on it and dragging it with the left mouse button pressed.

Setting of Magnifying Button
In the largest time scale “Hour” 1 day with 1 hour intervals will be displayed:

The “Shift” display will show you more days with an interval of 6 hours:

The “Day” setting displays entire days:

With the next click a month with its days will be displayed:
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The following setting shows you the month in terms of weeks.

The smallest time scale displays the quarters.

Modifying Section Width

In addition to the selection of the time scale, you have the possibility to change the 
section width within a chosen scale. To do so, click at any point in the time scale, 
and with the pressed mouse button change the width of section as desired. When 
you drag the mouse towards the left, you decrease the section width and increase it 
by dragging the mouse to the right.
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Time Reporting

General
To utilise time reporting only makes sense, if it covers the entire team and all its 
activities. As time reporting provides important information for the assessment of your 
projects, the standard mpp format of Microsoft Project is not suitable, since it can 
only contain one project. Time reporting using Afinion Project-Viewer, therefore, 
requires a database which contains all projects for which time shall be reported. 
Several databases may be used for different departments, yet consolidation of the 
data will then be more difficult.

Databases supported by Afinion Project-Viewer are:

mdb/mpd, the Microsoft Access database or the Microsoft Project database 
(actually the same with a different extension)

Microsoft SQL Server and the related Microsoft Project Server

Other databases, especially Oracle, would be possible. These are however bound to 
certain conditions by Microsoft Project. Please contact us, if you are interested.

Resource names can be selected arbitrarily. Decisive for the time reporting is the 
entry of the Windows user account in the corresponding field in Microsoft Project. For 
additional information see Chapter 2.3 below.

Time reporting with Afinion Project-Viewer does not require an extensive installation. 
By extracting the program files into a local folder everything is prepared and can be 
utilised by the project team members immediately, provided the project data have 
been saved in a database and the Windows user account has been entered for all 
resources.

In principle time reporting can be used as a front end for SAP or other ERP systems. To 
transfer the data correctly however requires some additional steps, that have to be 
determined in a definition process. Since Microsoft Project does not contain any 
security elements in this context, these have to be provided by the Afinion Project-
Viewer. Please contact us, if you are interested.

Afinion Project-Viewer Time Reporting is compatible with all versions of Microsoft 
Project 2000 and later. The support of Project 98 is not foreseen, since this version is 
not supported by Microsoft itself any more.

First Steps

Basic Decisions

Once you have decided to introduce time reporting using Afinion Project-Viewer 
some basic decisions have to be made. Please take your time for this, since the 
quality of your data will depend significantly on the prerequisites made here. The 
required steps are described below. 

Expand Timephased Data in Microsoft Project

In order to make the data transparent for Microsoft Project and to link them with the 
activities, in Microsoft Project go to menu Tools > Options, Register Save and activate 
“Expand timephased data in the database”. Press “Set as Default” in order to set this 
option automatically for every new project. This option has to be set before entering 
any time reporting data.
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Entering Windows Users in Microsoft Project

Open Microsoft Project and select the Resource Sheet.

Insert column “Windows User Account” unless a different field has been assigned 
(see Chapter 2.4, Selection 4)

For domain users enter “Domain\Login”, i.e. “MyCompany\MyLogin”, for users 
belonging to a workgroup or with standalone pc's enter “PC-Name\Login”, i.e. 
“MyPC\MyLogin”.

Field Mapping

Before setting up field allocations, you have to connect the Afinion Project-Viewer 
with a database. Either create a new, empty project in Microsoft Project and save it 
in a database or else, if you use Project Server, configure it directly. Time reporting in 
the Afinion Project-Viewer is completely independent of Microsoft settings. You 
cannot modify any Web Access data. Make sure however that the fields you want to 
use for time reporting have not been pre-assigned by the project manager. Normally 
these fields will be free. If not, assign different fields as described below.
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• Open Afinion Project-Viewer
• Go to menu Admin > Time reporting
• Enter the password (default password is “Apv1!” without quotation marks)
• Select the fields to be used for time reporting in Microsoft Project

These settings have the following properties:

Selection 1: Every resource can write
Default: Flag17
Properties: If the project manager sets this field to “no” or empty (default), 

only  the  resources  assigned  to  an  activity  may  report  work 
hours to this activity.  This setting corresponds to the Microsoft 
setting in Web Access. 
If  you  have  projects  where  the  members  should  be  able  to 
report  work  hours  quickly  and  instantly  to  any  or  selected 
activities, set this flag to yes. To set the flag for all activities insert 
the column in a Microsoft Project table, set the value for the first 
activity  to  “yes”  and  then  activate  the  entire  column  and 
select “Fill  down” from the Edit menu. Now every resource in 
the resource table may report work hours to these activities.

Alternative Fields: Flag  1  –  20,  Enterprise  Flag  1  –  20  (Enterprise  fields  are  only 
available when using Project Server)

Selection 2: Locked for time reporting
Default: Flag16
Properties: If this field is set to “no” or is left empty (default), every resource 

may report work hours to the corresponding activity. If it is set to 
“yes”, nobody – including assigned resources – may report work 
hours. This feature is useful, when external resources, which do 
not  have  access  to  the  time  reporting,  are  assigned  to  an 
activity and when an activity is completed and no further hours 
shall be booked. This also prevents belated bookings.

Alternative Fields: Flag  1  –  20,  Enterprise  Flag  1  –  20  (Enterprise  fields  are  only 
available when using Project Server)

Selection 3: %complete
Default: Number17
Properties: Every project  member can estimate his  progress  himself  and 

enter it  in the time reporting.  The program then calculates a 
total  progress  based  on  the  %complete  entered  by  the 
individual members and the total number of hours planned by 
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the project manager.
Example 1: Resource A has been assigned 10 h, resource B has 
been assigned 10 h. Resource A reports 40%, resource B reports 
60%. Afinion Project-Viewer now calculates 50% for the activity.

Example 2: Resource A has been assigned 10 h, resource B has 
been assigned 30 h. Resource A reports 5 h and 50%, resource B 
reports  10  h  and 33%.  Afinion  Project-Viewer  now calculates 
37.5% for the activity.

Alternative Fields: Number 1 – 20, Enterprise Number 1 – 40 (Enterprise fields are 
only available when using Project Server)

Selection 4: Windows Login
Default: Windows User Account
Properties: Defines which field is being used to link Afinion Project-Viewer 

with Microsoft Project resources.
Alternative Fields: Code, Text 1 – 20, Enterprise Text 1 – 40 (Enterprise fields are only 

available when using Project Server)
Important: Should you use a different field, i.e. Text1, please note that this is 

the Text1 field of the resource and not of the activity. To enter 
the user account you still  first  have to switch to the resource 
sheet and insert column Text 1 there.

Selection 5: Work
Default: Baseline Work 7
Properties: Field for consolidated work hours 
Alternative Fields: Baseline Work 1 – 10, Number 1 – 20
Important: The Baseline Work fields are used by Microsoft Project to store 

baselines. We therefore do not recommend using Baseline Work 
1 – 5.
The Baseline Work 1 – 20 fields do not exist in Microsoft Project 
2000. Use Number16 instead!

Using Time Reporting
Remember: Only MS Access and MSSQL Server project databases may be used for 
time reporting.

To report work hours for an activity, double-click on the task. The following window 

opens:

Enter the daily work hours in the fields between the <<< and >>> buttons.

Enter your completion estimate in percent in the field “%complete”.

Press Save.

Note: If the above window does not open by double-clicking the task, this may be 
due to:
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• Your login in the field “Window User Account” is missing or wrong.

• The project manager only allows assigned resources and you are not assigned 
to the selected activity.

• The project manager has blocked the activity.

View Progress in Microsoft Project

The sample project “Afinion.mpd” available from
 http://pmline.co.uk/en/downloads contains the sample view “*Time Report” 
showing both the standard progress (black bar) and the progress reported in the 
Afinion Project-Viewer (red bar). The report uses the table “*Time Report”. The sample 
has been set up using Microsoft Project 2000, i.e. the work hours reported are stored 
in field “Number16”.

The table of this report uses the following custom fields:

Actual Work Hours (Text16) Formula: [Number16] & " h"

Critical Work (Number15) Formula: [Work]-[Number16]
Graphical Indicators:

% Work Progress (Text17) Formula: [Number17] & “%”

Critical Deviation (Number18) Formula: [Number17]-[% Complete]
Graphical Indicators:

http://pmline.co.uk/en/downloads
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The bar chart contains the custom red work progress bar, which is defined as “from 
Start to Finish7”, whereby 

Hidden column (Finish7) Formula: 
ProjDateAdd([Start],[Duration]*[Number17]/100)

By using the Microsoft Project Organizer (menu Tasks > Organizer...) this sample view 
together with “*Setup Time Reporting”, the associated tables with the same names 
and the custom fields can be copied to your Global.mpt and from there to any 
existing or new project.
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Printing with the Afinion Project-Viewer

Click on the Printer icon in the menu bar to open a new window where you get 
possibilities to display the project in various sizes. By default the entire project is 
displayed on one page and there the view of the bar chart is minimized to a 
minimum percentage.

In the drop down menus the size of the bar chart can be altered.

The enlargement percentage can be increased to show the project on several 
pages. This helps to better display the details on one page. You can then print all the 
pages or the selected pages as required. As soon as the display of the Afinion 
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Project-Viewer is increased and it requires more than one page, the button in the 
drop down menu is activated. With a click on this button (“display one page”) all 
other buttons are activated, so that you can easily move from one page to another.

The Buttons of the Print Menu
This menu provides many buttons in order to optimise printing.

Close preview

Page setup

Print

Go to first page

Show previous page

Show next page

Show page above

Show page below

Go to last page

Display diagram with all pages

 Display diagram on one page

Show all the diagrams on one page

Position of the diagram on the page

Number of pages (up)

Number of pages (wide)

Font type

Page numbering

Print date

Header setup

Footer setup

Print chosen area

Choosing rows to print

As a standard setting, the diagram is aligned in the centre of the page, but you can 
change this property as required and the diagram can be viewed at other positions 
in the page. To do so, there are many options available in the drop-down menu 
shown on the left.



- 27 -

Client or Server Mode

Client Mode
If you choose the client mode the configuration file is placed in the APV directory. In 
that case you can install APV by simply copying it.

Server Mode 

Windows (Roaming User, Terminal Server, Citrix)

In „Server mode“ the configuration file needs to be placed in the user profile.

Possibilities:

• Several users can work with their individual settings on one computer
• Install  APV on  a  Server  to  allow several  users  to  work  with  APV  with  their 

individual settings.
• Roaming User
• Terminal Server, Citrix Meta Frame Server

Linux, Mac OS X, Solaris, and other Unix-Versions

Characteristical for Unix Versions is a $home directory for every user. Modifiable files 
have to be placed in the directory $home / ProjectViewer.

Afinion Project-Viewer and Outlook

Exporting Activities to Outlook
With Afinion Project-Viewer you have a possibility to export your activities from a 
project plan to the folder “Calendar” in Outlook. The corresponding button  is only 
activated if, while loading a plan, a resource selection has been made. The resource 
names in Microsoft Project will usually be different from those in Outlook. 

After you have pressed the Outlook button, a security warning appears.
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After confirming your actions, your activities are exported to the Outlook tasks in the 
personal folder, regardless of corresponding Outlook user and selected resource 
name.

Customising Outlook
In order to show more information from a project plan, the standard display of 
Outlook must be changed accordingly.

We do it in following way:

Click with the right mouse button on the header bar and select “Field Chooser”.
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Here you select “User defined fields in folder”. Choose Project and UID. In that field, 
press and hold the left mouse button, and drag the field into the header bar of 
Outlook.

In the next step select “Frequently-used fields”

There you have the choice between many different fields (for example % complete, 
notes etc.). Please proceed in the way explained above.

At the end of this procedure, you will see the display similar to that shown below.

The way you order your fields is up to you.
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Once you have entered the degree of completion of your work, respectively 
execution appended, the fields aren’t renewed. For example as shown below, with 
new Start and new End of activities (while rescheduling a project), the degree of 
completion won’t be overwritten. This assures that, although changes are made, the 
original entries aren’t overwritten.



- 31 -

Please note that when an assignment is closed and deleted, then it will be 
generated again during the next transfer of activities from the project plan, because 
there is no information sent back from Outlook to the project plan. It is advisable to 
insert the field “% complete” to control your assignments and appointments.

Uninstallation / Deletion of Afinion Project-Viewer
To uninstall APV from your computer double-click on uninstall.exe and follow the 
instructions. After that go to the directory in which APV has been installed, mark the 
file “ProjectViewer” and press “Delete” on your keyboard.
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