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1 Set-up of Afinion Project-Viewer

1.1 Download and Installation
Afinion Project-Viewer may be downloaded from our homepage 
http://www.afinion.com 
or the homepages of our distributors.

Extensive information as well as the download link is available at Software → Afinion 
Project-Viewer. As Afinion Project-Viewer is a Java application, it can be used on 
Windows PC, Mac (OS/X),  Linux and other Unix derivatives. Export to Outlook and 
access to Microsoft Office Project Database (or Access respectively) is only possible 
on the Windows operating system.

Important:  If you want to view SAP PS plans and if the SAP GUI is installed on your 
computer,  please read the installation instruction to be found on our  homepage 
before continuing.

Download the file Project-Viewer.exe (Windows) and then start it by double-click. 

Next you can associate .mpp files with Afinion Project-Viewer and then select the 
programme short cuts.

Now enter the path where you want to store the application in the following form. 
The default path is „C:\Program Files\Afinion Project-Viewer\“. You can change the 
target directory by clicking on Browse....

file:///C:/Program
http://www.afinion.com/
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The target directory will be created automatically, if it does not exist.

In the following window click Install.

In the final window click Finish to complete the configuration.

1.2 Start, Restart and Termination
Click on a shortcut either on the desktop or in the program menu in order to start the 
Viewer. The Viewer icon is now visible in the system tray. 

When you exit the application, the tray icon remains and it will stay there until you 
either close it (right-click, click Close fully) or shut down the computer.  To restart the 
Viewer, click on the system tray icon. This is much faster, since all the start-up files do 
not have to be reloaded. You can terminate application and system tray together 
by going to menu File → Close fully or right-clicking the tray icon and clicking Close 
fully.  

1.3 Read In License Key
Save the license key that you have received by e-mail on your hard disk. 

Start Afinion Project-Viewer and open menu Information → License information.

Read the license conditions and click Read license file.
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Now select the license file and click Open.

Confirm the message about the successful installation by clicking OK and then OK 
again in the license window. Now terminate the application completely (Menu File 
→ Close fully).

After restarting the application the message about the remaining test period should 
have disappeared and you should see the license information in the blue bar below 
the menu bar.
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In case you are unable to to read in the license file, you probably don't have write 
permissions in the directory so that the programme cannot save the license key. In 
such a case contact your administrator.

1.4 Language and Version Setup
Go to menu Administration. You are then asked to enter the administrator password.

Since there is no initial password set just click OK.

Now go to menu Administration > Change installation.

The following windows guide you through the configuration of the Afinion Project-
Viewer.

First select the language.

The next window lets you select between installation as a service or installation as an 
application.

Explanation: 
When installing the Afinion Project-Viewer as a service it will be loaded into system 
memory at computer start up. An icon in the system tray (on the right at the bottom 
of the screen) will show its presence. A single click on the icon immediately opens 
the Viewer. If the Viewer is the default application for .mpp files, a double click on an 
.mpp file will open the file instantly.

When  installing the  Viewer  as  an  application it  will  only  be  loaded when  either 
clicking on a startup icon or by double clicking a .mpp file.
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As long as you have not read in a purchased license key, you are then asked which 
version you want to test. 

Important:  You can test  every  version for  30  days  by selecting the version in this 
window. After 30 days the application will continue to work as free edition. If you 
would like to continue testing the application, you can request a special test key by 
e-mail to info@afinion.com, by calling +41 (0)56 267 4050 or by faxing to +41(0)56 267 
4051.

In the next step you can associate standard Microsoft Office Project files (.mpp) with 
Afinion Project-Viewer.

Please note: Only check this box, if Microsoft Office Project is  not  installed on your 
computer. Otherwise a double-click on an .mpp file will always start the viewer and 
not Project.

1.5 Server Configuration
The initial password required to enter the Server configuration is APV1!. This password 
is independent of the Administration password and is identical for all  users  of  the 
server  functionality,  ie  Time  Recording  and  Smart  Project  Server.  For  details  see 
Chapter 3 and Smart Project Server manual.

1.6 Windows Roaming User, Terminal Server, Citrix

1.6.1 Introduction
By default all user specific Information of the configuration file is saved in the user 
profile. This allows for 

• several users of a pc to work with their individual settings,

• installation of Afinion Project-Viewer on a server drive, several users to work 
with the programme and thereby use their own settings,

mailto:info@afinion.com
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• use of Roaming User,

• use of Terminal Server or Citrix MetaFrame Server.

1.6.2 Microsoft Windows Terminal Server and Citrix 
MetaFrame/XenApp

In order to use Afinion Project-Viewer with Microsoft Windows Terminal Server or Citrix 
Metaframe/XenApp instead of the standard start-up file  ProjectViewer.exe the file 
ProjectViewerS.exe has to be used.

• In order to link this version of Afinion Project-Viewer to .mpp files proceed as 
follows:

• Open Windows Explorer, Menu Tools > Folder Options...

• Select File Types and scroll down to MPP

• Click Change... and then Browse...

• Locate  and  select  ProjectViewerS.exe,  by  default  it  is  located  in 
C:\Program Files\Afinion\Afinion Project-Viewer

• In order to link the shortcuts on the desktop, in the Quick Launch toolbar and 
the  programs  menu,  right-click  the  shortcut,  select  Properties  and  then 
change the target field from  
“C:\Program Files\Afinion\Afinion Project-Viewer\ProjectViewer.exe”  
to  
“C:\Program Files\Afinion\Afinion Project-Viewer\ProjectViewerS.exe”.

Note: These modifications can also be made prior to installation in the installation 
packet,  which is temporarily stored in the folder  Application Data\Afinion\Afinion 
Project-Viewer\install in the user profile.

file:///C:/Program
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2 Viewing Projects with Afinion Project-Viewer

2.1 General
After opening Afinion Project-Viewer you will see the startup screen with links to 
various documents and information. Via the menu File you can now open either 
a .mpp, a .xls file or a database. You can also open a project from an existing 
database  or  access  a  project  from  Smart  Project  Server  via  its  security 
mechanisms. The latter is only available if you have licensed Smart Project Server.

2.2 Set-up of File Types and File Access

2.2.1 Afinion Project-Viewer with .mpp and .xls 
You can link to an .mpp or .xls plan directly:

• Go to menu File > Open and select the .mpp or .xls file
Alternatively

• Go to menu File > Load Project

2.2.2 Using the Connection Manager
If you want to directly access a database using Afinion Project-Viewer select menu 
File > Connection Manager.

This menu opens a window which allows you to access a .mpp file, an Access or SQL 
Server database, a database via DSN, SAP, Excel and XML (Project 2007). 

In order to create a connection to a database with Afinion Project-Viewer you first 
have  to  create  this  connection  using  the  connection  manager.  There  are  eight 
different methods available to access project data for all the different methods you 
have to store the projects. The different methods are described in detail below.

To create a new connection first click New and then select the correct tab (MPP, MS 
Access, ...).  Now enter the required connection data and save your entries. Click 
Connect to finally create the connection to the database.

If you have previously saved the connection data, select the database from the list 
above and click Connect.
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2.2.2.1 Projects in .mpp Format
• Click New and then select the MPP tab
• Press  the button  .  Now an explorer  window is opened where you can 

select the desired project.
• Click on Save to save the name and path in the list above.
• Click on Connect to open the following window:

This  example is  named “Engineering”.  Click  on the project  and press  the  button 
Load. If you (as shown in this example) have chosen not to select any resources, the 
whole content of the project will be displayed. You can pre-select a single resource 
so that only the activities to which that resource is assigned is shown.

Alternatively .mpp files can be opened directly as described in section 2.2.1.

2.2.2.2 MS Access Database
If  you are  using projects  in Microsoft  Access  formats,  ending with either  .mpd or 
.mdb, proceed as follows:.

• Go to menu File > Connection Manager
• Click on register MS Access
• Click on New 
• Press  the button  .  Now an explorer  window is opened where you can 

select the desired database.

In order to ascertain that the link to the database works press the button Test. When 
you  get  the  message  “link  checked  –  version  available”  you  can  save  the  test 
connection  by  pressing  Save. Then  press  “Connect”,  to  create  a  link  to  your 
database.
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Note:
At this point of time “only” the link to the database was established, so that it doesn’t 
have to be recreated every time you want to open the project. This link has no effect 
on the content of your database.

A new window is displayed, in which your link is shown.

This  example is  named “Engineering”.  Click  on the project  and press  the  button 
Load. If you (as shown in this example) have chosen not to select any resources, the 
whole content of the project will be displayed. Alternatively you can pre-select a 
single resource so that only the activities to which that resource is assigned is shown.
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Display of the complete databa se:

2.2.2.3 Afinion Project-Viewer with Microsoft SQL –Server
If  you  want  to  establish  a  link  to  an  SQL  database,  please  refer  to  your  system 
administrator for him to make the appropriate settings. Depending on the structure 
of your EDP-System, you may require settings that cannot be provided by the Project 
Viewer.

Start the Connection Manager, press New and then select the register MSSQL-Server.
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By clicking on the button Wizard you or your EDP administrator can enter the neces-
sary information, such as specific settings for the company and passwords. You can 
test the connection by pressing the button  Test If the connection is created press 
Save. The connection is saved immediately. As soon as the link is created and saved 
you can load the database.

2.2.2.4 Afinion Project-Viewer with DSN Connection
If you want to create a link to a database over a DSN connection, please refer to 
your  system  administrator  for  the  relevant  settings.  As  stated  above  we  cannot 
provide you with the specifications of your company.

By  clicking  on  the  button  Wizard  you  or  your  EDP  administrator  can  enter  the 
necessary information, such as specific settings for the company and passwords. You 
can test the connection by pressing the button Test If the connection is created press 
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Save. The connection is saved immediately. As soon as the link is created and saved 
you can load the database.

2.2.2.5 Afinion Project-Viewer and SAP PS
Important:
There is no installation of SAP GUI required to run the Project Viewer. 

If you do have installed the SAP GUI, please consider the following:
The Afinion Project-Viewer  requires  the file LibRfc32.dll  Version 6206.6.1456.4314  or 
higher.
This file must be copied into the directory Windows\system32.
You  will  find  the  file  in  Afinion  Project-Viewer  installation  directory.  The  default 
directory is:

 C:\Program Files\AfinionViewer\PViewer.

You can also download the file from SAP directly from  
http://service.sap.com/connectors  
Go to SAP Java Connectors\Tools & Services | Download SAP JCo Release 2.1.3 | 
Windows 2000,… - 32 bit SAP JCo 2.1.3 and download it as zip file.

After  copying  the  file  into  your  Windows\system32  directory,  you  can  create  a 
connection to your SAP Server. 

The Connection Manager offers the possibility to access a database of your choice. 
If  you  would  like  to  access  another  database,  you  have  to  establish  a  new 
connection with the Connection Manager.

To check if the connection to the database is functioning, press the button Test first. 
If you receive the message “Connection tested”, you can save your test-connection 
for the time being. Then press the button “Connect” to establish a connection to the 
database.

http://service.sap.com/connectors%20
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Click on one of the four radio buttons on top of the window to choose which data 
shall be displayed. On the left hand side of the window you have the opportunity to 
select a project definition (unless the radio button “network plan” was checked). On 
the right hand side of the window you can choose a single network plan (only if the 
radio button “network plan” is checked). Then press “Open”.

2.2.2.6 Afinion Project-Viewer with .xls (Excel)
Please note: The .xlsx format of Excel 2007 is not a .xls format. If you are using Excel 
2007 you have to save the table as Excel 2000-2003!

The Excel table should contain the column names in the first row.

When you open the table, it will normally be shown without bars. You then have to 
assign the required headers to the columns. To do this right-click in the header and 
select the corresponding value:

Start: Defines the start of the bar

Finish: Defines the end of the bar

Level and/or Hierarchy: Defines the work breakdown structure. You can use either 
a  level  information,  e.g.  1,  2,  3,  etc  or  a  proper  work 
breakdown structure, e.g. 1, 1.1, 1.1.1, 1.1.2, 1.2 etc. When 
you  use  the  hierarchy,  the  numbers  themselves  are 
irrelevant, the dot separator is important!
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Predecessor: Defines the links between tasks . Multiple links have to be 
separated by semicolon. This function is restricted to Finish-
Start relations.

Text field: Defines the corresponding column as text and only shows 
the field in the table part of the view.

Indented text field: Uses  the  Level  or  Hierarchy  field  (whichever  has  been 
assigned last) to structure the display of the text and show 
the bars as summary or normal bars.

2.3 Operation

2.3.1 General 

The APV shows  the activities of the project on the left hand side and a bar chart 
(Gantt) on the right hand side. Vertical red lines indicate the start and the end of the 
project. Actual project, resource (in case you have chosen one) and actual date 
are displayed in the title bar.
In the task bar on the left you can choose different Gantt Charts and Views used by 
the project manager in Microsoft Project. The view “My View” is a standard view in 
which the user has the possibility to create and save an individual view (see page 
below).
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The menu bar contains five menus:

2.3.1.1 File
Click on „Open” to directly open an existing .mpp, mpd, mdb, xls  or xlm file. An 
explorer window to choose your file will be opened.

The subsidiary menu “Connection Manager” opens the Connection Manager. Use 
the Connection Manager as described above.

The  subsidiary  menu  „Load  Project“  opens  a  window  displaying  the  actual 
connection to a database. In that window you can choose a different project from 
the actual database.

“Open with SPS” is only available, if you have licensed the Smart Project Server.

“Export tasks to Outlook” exports the tasks for the selected resource to Outlook. See 
Chapter 5 for details.
Note: This menu is only visible in “Expert Menu” mode (see Administration below).

Click „Exit“ to close APV.

Click “Close Fully” to terminate the resident application as shown by the icon in the 
system tray as well.

2.3.1.2 View
Here you you can enlarge or reduce the time scale.

Additionally you have the alternative to enlarge or to reduce the display.

By clicking on the „Expand Node” or the “Collapse Node“, you can choose between 
partial display and full display of the activities.

“Enable / Disable Links” displays the connections in the bar chart.

“Fit in Window” scales the view, so that the whole project is displayed in the bar 
chart. 

“Date Format” lets you select different date formats as well as selecting your own.
Note: This menu is only visible in “Expert Menu” mode (see Administration below).

“Language” allows you to select the programme language.
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2.3.1.3 Administration
At first you need to select “Open Configuration” and then enter the administrator 
password. This will activate the full menu. When you close the Afinion Project-Viewer 
completely (Menu “Close fully”) and restart it, the full menu will be hidden again.

Note: When there is no password set, the full menu is always visible.

“Menu Mode” provides two sub-menus:

● “Normal Menu” hides the menus “Export tasks to Outlook” (File) and “Date 
Format” (View).

● “Expert Menu” shows these two menus.

“Change  password”  allows  you  to  set  or  change  the  password  used  for 
administrative tasks.

Note: This password is only valid for the Administration menu.

“Change  Installation”  starts  a  wizard  which  provides  a  window  to  select  the 
language and a window to select the start-up mode:

● When installing the Afinion Project-Viewer as a service it will be loaded into 
system memory at computer start up. An icon in the system tray (on the right 
at the bottom of the screen) will show its presence. A single click on the icon 
immediately  opens  the  Viewer.  If  the Viewer  is  the default  application for 
.mpp files, a double click on an .mpp file will open the file instantly.

● When installing the Viewer as an application it will only be loaded when either 
clicking on a start-up icon or by double clicking a .mpp file.

“Install AddIn” is only relevant for users of the Smart Project Server (SPS). For details 
see Smart Project Server manual, available at 
http://pmline.co.uk/Downloads/Docs/SPS_Manual_11.pdf

“Define initial screen” allows you to replace the start-up screen by your own HTML or 
HTM file. After a system restart your new start-up screen will be activated. This feature 
is especially useful to link the Project Viewer to your company intranet.

With “Select logo” you can integrate your company logo, which will then be shown 
on all printouts. The picture has to be GIF, JPG or PNG format. Afinion Project-Viewer 
does not scale the picture, a size of approx. 60 x 60 pixels is recommended.

With  “Manage  menus”  the  administrator  can  define  in  detail,  which  menus  are 
available for the user.

2.3.1.4 Server
Important:  The  “Server”  menu  can  only  be  used  in  conjunction  with  project 
databases!

http://pmline.co.uk/Downloads/Docs/SPS_Manual_11.pdf
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The “Server” menu initially only contains one sub-menu: “Open configuration”. When 
you select this menu, you are asked to enter the server password.

Note: This password is independent of the password in the “Administration” menu. 
The password Apv1! is preassigned.

When you open the “Server” menu again, you will now have the following entries:

● “Time Reporting”. See chapter 3 for details.

● “Change Time Reporting Password”.

● Menus  relating  to  Smart  Project  Server  set-up  (only  for  users  of  the  Smart 
Project Server). For details see Smart Project Server manual, available at 
http://pmline.co.uk/Downloads/Docs/SPS_Manual_11.pdf

2.3.1.5 Information
Contact and license information.

2.3.2 Resource Controlled Display
When starting Afinion Project-Viewer you have the possibility to display a dedicated 
or assigned resource only. Available resources are shown in a the list on the right.
If  there  are  several  projects  in  the  database,  all  activities  of  one resource in all 
projects may be viewed.

In  addition,  there  is  the  possibility  to  choose  the  resources  in  a  loaded  plan:

http://pmline.co.uk/Downloads/Docs/SPS_Manual_11.pdf
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After doing so, the displayed information is refreshed, and all  the activities of  the 
chosen resource are shown.
E.g.  in  the  case  of  vacation  replacement  the  display  can  be  set  to  show  the 
activities  of  a  colleague  (resource)  and  the  assignment  being  viewed  can  be 
exported to Outlook. More on this will be explained later.

2.3.3 The Toolbar of Afinion Project-Viewer

The icons have the following functionality:

Opens the explorer window to select and open an .mpp file

Opens the window with your actual database connection to choose a 
different project

Opens the Connection Manager

Sets the time scale in the bar chart

Sets the unit width in the bar chart

Magnifying button to enlarge the time scale 

Magnifying button to reduce the time scale

Magnifying button to enlarge the table display

Magnifying button to reduce the table display

Print. Page preview and setup (see chapter Error: Reference source not

found)

Exports assignment and appointments to outlook

Expands tree

Collapses tree

Shows connections in the bar chart

Hides connections in the bar chart
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Fits the bar chart in order to display the entire project

Displays contact information

License agreement

All icons are displayed with tool tips, which will provide additional information when 
the mouse is moved over the selected icon.

2.3.4 Change / Adjust the Table View
If you press the left mouse button in the head area of the columns, you can move 
the  selected  column.  This  allows  you  to  order  the  columns  according  to  your 
requirements and priorities. In order to increase or decrease the width of the rows, 
click on the border  of  the row-header  and move it  to  the right or  the left  while 
keeping the mouse button pressed, exactly as it is done in Excel.

2.3.5 Enlarge / Reduce the Bar Chart (Gantt)

If you want to enlarge or reduce the bar chart press one of the black arrows on top 
of the bar between bar chart and table pointing left or right. Alternatively you can 
move the bar by clicking on it and dragging it with the left mouse button pressed.

2.3.6 Setting of Magnifying Button
In the largest time scale “Hour” 1 day with 1 hour intervals will be displayed:
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The “Shift” display will show you more days with an interval of 6 hours:

The “Day” setting displays entire days:

With the next click months and weeks will be displayed:

The following setting shows months.

The smallest time scale displays the quarters.
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2.3.7 Modifying Section Width

In addition to the selection of the time scale, you have the possibility to change the 
section width within a chosen scale. To do so, click at any point in the time scale, 
and with the pressed mouse button change the width of section as desired. When 
you drag the mouse towards the left, you decrease the section width and increase it 
by dragging the mouse to the right.

2.3.8 Setting the Date Format
Select „View > Date format“:

Either select a format from the „Date format“ pull-down list or enter your own format 
in the „Date code“ field.
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3 Time Recording

3.1 General
To utilise Time Recording only makes sense, if it covers the entire team and all  its 
activities. As Time Recording provides important information for  the assessment of 
your projects, the standard mpp format of Microsoft Project is not suitable, since it 
can only contain one project. Time Recording using Afinion Project-Viewer, therefore, 
requires a database which contains all  projects for which time shall  be reported. 
Several databases may be used for different departments, yet consolidation of the 
data will then be more difficult.

Databases supported by Afinion Project-Viewer are:

● mdb/mpd, the Microsoft Access database or the Microsoft Project database 
(actually the same with a different extension)

● Microsoft SQL Server and the related Microsoft Project Server

Other databases, especially Oracle, would be possible. These are however bound to 
certain conditions by Microsoft Project. Please contact us, if you are interested.

Resource names can be selected arbitrarily. Decisive for the Time Recording is the 
entry of the Windows user account in the corresponding field in Microsoft Project. For 
additional information see Chapter 3.3 below.

Time Recording with Afinion Project-Viewer does not require an extensive installation. 
By extracting the program files into a local folder everything is prepared and can be 
utilised by the project team members immediately, provided the project data have 
been saved in a database and the Windows user account has been entered for all 
resources.

In principle Time Recording can be used as a front end for SAP or other ERP systems. 
To transfer the data correctly however requires some additional steps, that have to 
be determined in a definition process. Since Microsoft Project does not contain any 
security elements in this context, these have to be provided by the Afinion Project-
Viewer. Please contact us, if you are interested.

Afinion Project-Viewer  Time Recording is  compatible with  all  versions  of  Microsoft 
Project 2000 and later. The support of Project 98 is not foreseen, since this version is 
not supported by Microsoft itself any more.

3.2 First Steps

3.2.1 Basic Decisions
Once you have decided to introduce Time Recording using Afinion Project-Viewer 
some basic decisions have to be made. Please take your time for this, since the 
quality of your data will depend significantly on the prerequisites made here. The 
required steps are described below. 

3.2.2 Expand Time Phased Data in Microsoft Project
In order to make the data transparent for Microsoft Project and to link them with the 
activities, in Microsoft Project go to menu Tools > Options, Register Save and activate 
“Expand timephased data in the database”. Press “Set as Default” in order to set this 
option automatically for every new project. This option has to be set before entering 
any Time Recording data.
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3.2.3 Entering Windows Users in Microsoft Project
Open Microsoft Project and select the Resource Sheet.

Insert column “Windows User Account” unless a different field has been assigned.

For  domain  users  enter  “Domain\Login”,  i.e.  “MyCompany\MyLogin”,  for  users 
belonging  to  a  workgroup  or  with  standalone  pc's  enter  “PC-Name\Login”,  i.e. 
“MyPC\MyLogin”.

3.2.4 Field Mapping
Before setting up field allocations, you have to connect the Afinion Project-Viewer 
with a database. Either create a new, empty project in Microsoft Project and save it 
in a database or else, if you use Project Server, configure it directly. Time Recording in 
the  Afinion  Project-Viewer  is  completely  independent  of  Microsoft  settings.  You 
cannot modify any Web Access data. Make sure however that the fields you want to 
use  for  Time  Recording  have  not  been  pre-assigned  by  the  project  manager. 
Normally these fields will be free. If not, assign different fields as described below.
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1Open Afinion Project-Viewer
2Go to menu Admin > Time Recording
3Enter the password (default password is “Apv1!” without quotation marks)
4Select the fields to be used for Time Recording in Microsoft Project

These settings have the following properties:

Selection 1: Every resource can write
Default: Flag17
Properties: If the project manager sets this field to “no” or empty (default), 

only  the  resources  assigned  to  an  activity  may  report  work 
hours to this activity. This setting corresponds to the Microsoft 
setting in Web Access. 
If  you  have projects  where  the  members  should  be able  to 
report  work  hours  quickly  and  instantly  to  any  or  selected 
activities, set this flag to yes. To set the flag for all activities insert 
the column in a Microsoft Project table, set the value for the first 
activity  to  “yes”  and  then  activate  the  entire  column  and 
select “Fill  down” from the Edit menu. Now every resource in 
the resource table may report work hours to these activities.

Alternative Fields: Flag 1  –  20,  Enterprise  Flag 1  –  20  (Enterprise  fields  are  only 
available when using Project Server)

Selection 2: Locked for Time Recording
Default: Flag16
Properties: If this field is set to “no” or is left empty (default), every resource 

may report work hours to the corresponding activity. If it is set to 
“yes”, nobody – including assigned resources – may report work 
hours. This feature is useful, when external resources, which do 
not  have access  to  the Time Recording,  are assigned to an 
activity and when an activity is completed and no further hours 
shall be booked. This also prevents belated bookings.

Alternative Fields: Flag 1  –  20,  Enterprise  Flag 1  –  20  (Enterprise  fields  are  only 
available when using Project Server)

Selection 3: %complete
Default: Number17
Properties: Every project  member  can estimate his  progress  himself  and 

enter it in the Time Recording. The program then calculates a 
total  progress  based  on  the  %complete  entered  by  the 
individual members and the total number of hours planned by 
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the project manager.
Example 1: Resource A has been assigned 10 h, resource B has 
been assigned 10 h. Resource A reports 40%, resource B reports 
60%. Afinion Project-Viewer now calculates 50% for the activity.

Example 2: Resource A has been assigned 10 h, resource B has 
been assigned 30 h. Resource A reports 5 h and 50%, resource B 
reports  10  h  and 33%.  Afinion Project-Viewer  now calculates 
37.5% for the activity.

Alternative Fields: Number 1 – 20, Enterprise Number 1 – 40 (Enterprise fields are 
only available when using Project Server)

Selection 4: Windows Login
Default: Windows User Account
Properties: Defines which field is being used to link Afinion Project-Viewer 

with Microsoft Project resources.
Alternative Fields: Code, Text 1 – 20, Enterprise Text 1 – 40 (Enterprise fields are only 

available when using Project Server)
Important: Should you use a different field, i.e. Text1, please note that this is 

the Text1 field of the resource and not of the activity. To enter 
the user account you still  first have to switch to the resource 
sheet and insert column Text 1 there.

Selection 5: Work
Default: Baseline Work 7
Properties: Field for consolidated work hours 
Alternative Fields: Baseline Work 1 – 10, Number 1 – 20
Important: The Baseline Work fields are used by Microsoft Project to store 

baselines. We therefore do not recommend using Baseline Work 
1 – 5.
The Baseline Work 1 – 20 fields do not exist in Microsoft Project 
2000. Use Number16 instead!

3.3 Using Time Recording
Remember: Only MS Access and MSSQL Server project databases may be used for 
Time Recording.

To report work hours for an activity, double-click on the task. The following window 

opens:

Enter the daily work hours in the fields between the <<< and >>> buttons.

Enter your completion estimate in percent in the field “%complete”.

Press Save.

Note: If the above window does not open by double-clicking the task, this may be 
due to:
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• Your login in the field “Window User Account” is missing or wrong.

• The project manager only allows assigned resources and you are not assigned 
to the selected activity.

• The project manager has blocked the activity.

3.3.1 View Progress in Microsoft Project
The sample project “Afinion.mpd” available from
 http://pmline.co.uk/en/downloads contains  the  sample  view  “*Time  Report” 
showing both the standard progress (black bar) and the progress reported in the 
Afinion Project-Viewer (red bar). The report uses the table “*Time Report”. The sample 
has been set up using Microsoft Project 2000, i.e. the work hours reported are stored 
in field “Number16”.

The table of this report uses the following custom fields:

Actual Work Hours (Text16) Formula: [Number16] & " h"

Critical Work (Number15) Formula: [Work]-[Number16]
Graphical Indicators:

% Work Progress (Text17) Formula: [Number17] & “%”

Critical Deviation (Number18) Formula: [Number17]-[% Complete]

http://pmline.co.uk/en/downloads
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Graphical Indicators:

The bar chart contains the custom red work progress bar, which is defined as “from 
Start to Finish7”, whereby 

Hidden column (Finish7) Formula: ProjDateAdd([Start],
[Duration]*[Number17]/100)

By using the Microsoft Project Organizer (menu Tasks > Organizer...) this sample view 
together with “*Setup Time Recording”, the associated tables with the same names 
and the custom fields can be copied to your Global.mpt  and from there to any 
existing or new project.
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4 Afinion Project-Viewer and Outlook

4.1 Exporting Activities to Outlook
With Afinion Project-Viewer you have a possibility to export  your  activities from a 
project plan to the folder “Calendar” in Outlook. The corresponding button  is only 
activated if, while loading a plan, a resource selection has been made. The resource 
names in Microsoft Project will usually be different from those in Outlook. 

After you have pressed the Outlook button, a security warning appears.

After confirming your actions, your activities are exported to the Outlook tasks in the 
personal  folder,  regardless  of  corresponding Outlook  user  and selected resource 
name.

4.2 Customising Outlook
In  order  to  show  more  information  from a  project  plan,  the  standard  display  of 
Outlook must be changed accordingly.

We do it in following way:

Click with the right mouse button on the header bar and select “Field Chooser”.
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Here you select “User defined fields in folder”. Choose Project and UID. In that field, 
press and hold the left  mouse button,  and drag the field into the header bar of 
Outlook.

In the next step select “Frequently-used fields”

There you have the choice between many different fields (for example % complete, 
notes etc.). Please proceed in the way explained above.

At the end of this procedure, you will see the display similar to that shown below.

The way you order your fields is up to you.
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Once  you  have  entered  the  degree  of  completion  of  your  work,  respectively 
execution appended, the fields aren’t renewed. For example as shown below, with 
new Start and new End of activities (while rescheduling a project),  the degree of 
completion won’t be overwritten. This assures that, although changes are made, the 
original entries aren’t overwritten.
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Please  note  that  when  an  assignment  is  closed  and  deleted,  then  it  will  be 
generated again during the next transfer of activities from the project plan, because 
there is no information sent back from Outlook to the project plan. It is advisable to 
insert the field “% complete” to control your assignments and appointments.
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5 Printing with the Afinion Project-Viewer

Click on the Printer icon in the menu bar to open a new window where you get 
possibilities  to  display  the  project  in  various  sizes.  By  default  the  entire  project  is 
displayed  on  one  page  and  there  the  view of  the  bar  chart  is  minimized  to  a 
minimum percentage.

In the drop down menus the size of the bar chart can be altered.

The  enlargement  percentage  can  be  increased  to  show  the  project  on  several 
pages. This helps to better display the details on one page. You can then print all the 



- 36 -

pages  or  the selected pages  as  required.  As  soon as  the  display  of  the  Afinion 
Project-Viewer is increased and it requires more than one page, the button in the 
drop down menu is activated. With a click on this button (“display one page”) all 
other buttons are activated, so that you can easily move from one page to another.

The Buttons of the Print Menu
This menu provides many buttons in order to optimise printing.

Close preview

Page setup

Print

Go to first page

Show previous page

Show next page

Show page above

Show page below

Go to last page

Display diagram with all pages

 Display diagram on one page

Show all the diagrams on one page

Position of the diagram on the page

Number of pages (up)

Number of pages (wide)

Font type

Page numbering

Print date

Header setup

Footer setup

Print chosen area

Choosing rows to print

As a standard setting, the diagram is aligned in the centre of the page, but you can 
change this property as required and the diagram can be viewed at other positions 
in the page. To do so, there are many options available in the drop-down menu 
shown below.
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6 User Specific Information 

6.1 Windows (Roaming User, Terminal Server, Citrix)
By default all user specific information is saved in the user profile.

Possibilities:

• Several users can work with their individual settings on one computer
• Install  APV on  a  Server  to  allow several  users  to  work  with  APV with  their 

individual settings.
• Roaming User
• Terminal Server, Citrix Meta Frame Server

6.2 Linux, Mac OS X, Solaris, and other Unix-Versions
Characteristical for Unix Versions is a $home directory for every user. Modifiable files 
have to be placed in the directory $home/.ProjectViewer.
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7 Application Termination
When you shut the Afinion Project-Viewer down, the system tray entry will  still  be 
activated. Click this icon to re-open the application instantly. 

Right-click the icon and then click  Close fully or  select Menu  File > Close fully to 
completely terminate the application .

Note: If you start Afinion Project-Viewer via a shortcut while the task list icon is still 
visible, you will open a second instance of the application instead.
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8 Deinstallation of Afinion Project-Viewer
In order to remove Afinion Project-Viewer from your pc restart the set-up  Project-
Viewer.exe and select “Remove” to deinstall the application:

Alternatively start Control Panel → Add or Remove Programs, select Afinion Project-
Viewer and click Remove.
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