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Introduction
Visual-Adress is the universal tool for your Sales and Marketing Department and for your professional 
staff at the business front.

The Visual-Adress application suite consists of several programmes. These individual programmes 
are briefly introduced below. This manual describes the use of Visual-Admin. 

Visual-Adress
The entire application is focused on convenient address management. It also links together notes, 
address-related documents and schedules.

• Selection windows containing master data
• Automatic testing for duplicated addresses
• Postcode file with cities and dialling codes where available
• Country-specific address editing
• Phone dialling by modem

Visual-Admin
In the database designer you can easily adapt your own data tables to your organisation’s require-
ments, design and save the layout of screen input forms.

• Database designer for various data formats
• Online links to external data
• Client management of up to 255 address masters 
• Screen layout for master data and notes

Visual-List Designer
The integrated list designer allows you to design all reports according to your preferences. By using 
drag and drop you can supplement, copy and adapt existing reports. The list designer unifies the 
convenient operating features of a modern word processor.

• Access to all data fields
• Group indices and arithmetic functions
• Integration of graphics, lines and frames design

Visual-Switch
This programme allows laptop users to switch between local and server based data.

Visual-Exchange
This  programme  allows  bidirectional  synchronisation  of  all  data  processed  with  Visual-Adress 
between server and client installations. This includes addresses including their add-on information, 
notes and dates as well as linked documents processed with e.g. Word or Excel.

Included in the basic version of Visual-Adress is the “Light” version of Visual-Exchange. This version 
allows to synchronise data for laptops, which are connected directly to the network, e.g. for field 
staff.

Visual-Synchro
This programme allows bidirectional synchronisation between Visual-Adress and Microsoft Outlook.

Visual-OLE (Automation Server)
Together with Visual-Adress you also received an OLE Automation Server (OLE). It allows external 
applications, e.g. order processing, to directly access the addresses in Visual-Adress. Examples and 
suggestions are included as Word documents. The OLE interface assumes programming knowledge 
and is mainly designed for software developers and experienced users.



Visual-Admin Basics
Visual-Admin is the application to set up most functions available in Visual-Adress. It is used to cus-
tomise Visual-Adress to the needs of your company.

Visual-Admin intervenes deeply with the structure of the Visual-Adress database. You can change 
and set many parameters in Visual-Admin directly. It is however designed to allow its operation by 
a trained user. It is recommended to assign a dedicated administrator, if you have set up a multi-
user system.

Start-up and Personal Settings

Start-Up
Note:
Access to Visual-Admin has to be exclusive, i.e. no other users may be logged into the database 
at the same time.

To start Visual-Admin go to Start > All Programs > Visual-Adress > Visual-Admin.

Menu Bar
The menu bar shows different icons depending on which main window is open.

- To adapt the menu bar to your personal preferences first open the main window (Current 
Users, General, Database Tables, etc.) for which you want to adapt it.

- Then click on the down arrow at the end of the menu bar or right-click in the menu bar.
- To insert a command select an existing command or separator on the right part, then select 

the command to add from the left part and press the right arrow. The new command will 
be inserted above the command selected on the right part.

- To remove a command select it and press the left arrow.

Menu Window
Here you can set the display to 640/480, 800/600, 1024/768 and full screen. By this you can check 
whether all forms will be shown completely on all screens in use at your company. To check select 
the smallest display used.



Current Users
After starting up Visual-Admin you find yourself in the overview of the current users. If there are other 
users logged in except yourself, you cannot save any modifications to the database structure or 
forms.



General
The general area deals with user independent settings, which are valid for all users. Most settings 
are valid for the entire installation, i.e. all clients.

Settings
Most settings are self explanatory, but a few tips may be of help:

Standard Language
You will normally set this to English, the language used in your company. Visual-Adress uses the cor-
responding language dependant functions based on this setting.

Standard Country Code
Use “GB” for Great Britain (not “UK” for United Kingdom). The value entered here is the default 
value for new addresses.

Standard Country Dialling Code
Use the new notation, i.e. “+44” for GB. This code will be used for the default country dialling code 
of new telephone and fax numbers.

Maximum (Number Of) Address Rows
This is the maximum number of rows that Visual-Adress uses to compose the address block.

Note:
Remember that when you change this number, lists and letter templates may have to be adap-
ted accordingly.

Maximum (Number Of) Rows in Combo Boxes
Combo boxes show data from which you may select an entry.  In order to limit the number of 
entries you can add the maximum value here. This setting does not influence the number of con-
current visible entries.

File Extension for User Pictures
Here you enter the bitmap type of the picture and signature you can assign to all users in the user 
administration. Possible types are .gif, .tif, .bmp, .jpg etc.

Unique Address Numbers
Although Visual-Adress disposes of a unique internal key (RecordID), you may wish to maintain a 
unique visible address number as well. If yes, activate this option.

Use Street and Post Office Box in the Address Block
By default, a post office box address overwrites the street address. To show both street and post of-
fice box activate this option.

Department above the Person in Charge
Option activated Option not activated

Company
Department
Person In Charge (Contact)
Address

Company
Person In Charge (Contact)
Department
Address



User Home Directory
Instead of having to enter user name and password at every start-up, you can enter a path here, 
which is formally identical but physically on each user’s pc. If this field contains a valid path name, 
Visual-Adress stores user name and password in this directory.

Font
Select  font  script  “-  Western  -”  or  “Central  European”  to  enable  the  font  selection  for 
English/French/German/etc. or any other of the available scripts for other languages.

Telephone Numbers
In order to obtain a uniform display of telephone numbers, use the fields for country and area dial-
ling codes as well as the telephone number correctly. The settings on this register convert the “+” 
into “00” and separate the 3 telephone number parts with the symbols entered.

Clients
In the Clients Register you create, administer and delete clients. Each client consists of a self con-
tained database. All data and documents are being saved independent of other clients. Only one 
productive client should exist for normal use.

Designation
This is the name that you select when logging in. You can use any sensible name.

Folder
By default the database will be stored in the directory  \\Server\...\Abex6\Data\(Folder), where 
(Folder) is the name entered here. The name generated from the designation may be overwritten.

Client Number
The client number is created automatically and cannot be modified.

Database Password
You can optionally assign a database password to every client.  This password prohibits  anyone 
from accessing the database via an external application.

External Address Database Active
Visual-Admin contains a number of predefined connections to other databases. You can connect 
these easily by using the wizard. Other data models are available on request.

Sesam Connection
This is a specific connection to Sage Sesam, allowing you to transfer data to Sesam including the or-
der in which they will be displayed there.

Record Locking on User or Group Level
An owner can be determined for all addresses, note types and tables. All data tables contain an 
“owner” field. If “entry for all” is entered there, everybody is authorised to modify or delete the re-
cord. If a certain staff member or group is entered, only that member or members of that group are 
authorised. This option is activated by enabling the respective checkbox.

If an assigned staff member leaves the company or someone else is assigned for other reasons, the 
administrator can transfer the ownership to the new person.

Create a New Client
- While in the Clients register go to menu File > New Client or click on the New Client icon. 
- Name the new client. When pressing the   icon, you can enter names in the other lan-

guages (French, German and Italian). The folder name is then assigned automatically, using 

file://Server/.../Abex6/Data/(Folder


the client  name without  blanks.  You can however overwrite  the folder  name. All  future 
entries including the documents will be stored in this folder and its sub-folders.

- Select an empty or an existing client as template. If you select an existing client, deselect 
the data, that should not be copied to the new client. Then only the database structure will 
be copied.

Deletion of an Existing Client
Highlight the client to be deleted and press the Delete icon or hit the Delete key. The client includ-
ing all data and documents will be deleted  irrevocably. It is strongly recommended to make a 
backup of the client folder first.

Salutation Allocation
These are the basic settings used in conjunction with external applications.

Search Keys
Here you can define how the search key for the addresses is edited. The default length is 15 char-
acters.  The default is  a special field, either the company name or, if  it is  empty,  surname + first 
name.

Using Add additional fields can be added, using Remove they can be removed. Properties shows 
details of the current selection and allows editing. The individual fields can be added completely or 
limited to a number of characters beginning from left or from right.  Standard resets everything to 
the default.

Duplicates Test
In the Duplicates Test register you determine which fields or parts of fields will be used to test for du-
plicate addresses. 

To be successful clear rules have to be established regarding how addresses should be entered. 
Out of experience we know that the same address can be written in dozens of different versions. 
Duplicates tests only return all (or almost all) existing duplicates, when the address fields are used 
for the address part for which they were designed.



The buttons  Add, Remove, Properties and Standard have the same functionality as under Search 
Keys above.

Copy Address
Here you can add the fields, which should not be copied when copying an address. We suggest 
adding the field “Address number” here.

Sub-Addresses
In the Sub-Addresses  register you determine which fields will be copied from the main address to 
the sub-address. By default all fields except data regarding the person are selected. 

This definition is being used when you click Copy as Sub-Address in Visual-Adress.

Address Links
In the Address Links register you determine which fields will be modified in the sub-addresses when 
you modify them in the main address. Only fields having identical values before the modification is 
made will be updated.

Reorganisation

Repair
You may sometimes have to repair the database. This can happen when someone shuts down his 
computer without first exiting Visual-Adress or when a network connection is lost while a user was 
editing a record. In this case click the Repair button to rebuild the database and all indices. Note 
that a temporary copy of the database is made, requiring additional disk space of the same size as 
the original database.

Detach
If a main address has been deleted without first releasing the links to sub-addresses, links leading 
nowhere may remain. This function checks all links and deletes invalid ones.

Delete (Notes and Documents)
Deletes all notes and documents for which the originally assigned address is missing.

Optimise
With time the database grows disproportionate to the number of entries, since deleted records 
physically remain in the database. While performance is hardly increased, the size of the database 
can be kept smaller. Perform this function monthly and after every repair.



Data Tables

Introduction
Due to the use of Access databases the functionality of Visual-Adress can be extended in an al-
most unlimited way. You can create new tables with new input forms, add or modify fields, link ex-
ternal data, etc. 

Visual-Adress contains three different kinds of tables:

- Address table
- Notes tables (internal and external)
- Master tables (internal and external)

Technically these tables are identical but their function is different. The address table is the main 
table with up to 255 individual fields. To improve the overview, the various fields can be assigned to 
up to 20 registers. 43 fields are predefined and cannot be deleted. The remaining fields are at your 
free disposal. The notes tables contain additional data that is usually linked to an address. Notes 
can be anything you like as well as special tasks and dates tables. Master tables contain data, 
which is used in drop-down boxes as predefined values for fields in other tables.

Database Design

Preparation
Although a database can be modified anytime later, some advance thoughts on what objectives 
shall be reached should be made beforehand. Draft the tables, fields and relations you need be-
fore creating or modifying them in Visual-Admin.

Create / Edit a Database
To create a new database see chapter “Clients”.

To edit a database select the Data Tables work area and go to menu File > Switch Client to select 
the appropriate database.

Create / Edit Tables and Form Design

Internal Tables
The procedure to add/edit tables and design the input forms is identical for all 3 types of tables.

- Go to menu File > New Internal Table or click on  to create a new master table; 
or  
go to menu File > New Internal Note Type or click on  to create a new note type.

- Enter a designation for the table. The internal name is created based on the designation.

External Tables
In order  to  avoid  redundant entry  of  data that  already exists  elsewhere, you can link external 
tables.

- Go to menu File > New external Table or click on  to link an external master table;
or  
go to menu File > New external Note Type or click on  to link an external note type.

- A wizard will guide you further.

Registers
If you need many fields they should be distributed on several  registers  to improve the handling 
thereof. To add a new register:



- Select the appropriate table.
- Select the register below which you want to add a new register (later rearrangement of the 

registers is not possible).
- Press the New button.
- Enter a short, distinctive register name.

Use as Address Register

If you want to use the register for additional address table fields, press OK after entering the desig-
nation.

Use as Mirrored Notes Register

All note types are always shown in the “History” register. To show important note types in a separate 
register proceed as follows:

- Select the table “Addresses”.
- Create a new register as described above.
- Click on the Notes register.



- Select the note types you want to show on this register.

Registers on Note and Master Tables

To create additional registers on note and master tables, select the appropriate table. Then pro-
ceed as for “Use as Address Register” above.

Database Fields
The fields are being created, edited and deleted on the Fields register.

Attention:
Fields in grey cannot be deleted and their data type cannot be changed, since these fields are 
compulsory for the application to work.

Visual-Adress contains many different field types with specific uses:

Field Type Description Field size (digits/ 
characters)

default

Arithmetic Field Calculates a value from other fields. Possible operations 
are
- Addition and subtraction

-



Field Type Description Field size (digits/ 
characters)

default

- Multiplication and division
- Percentages
- Exponentiation

Date Date -
Depending on se-
lection

When selecting an entry in a selection field, the value of 
the depending field is shown here.

-

E-mail address E-mail address 50
Fax number Fax number excluding country and area codes 20
Internet address Internet URL http:// or https:// 60
IP-Telephone VOIP telephone code or number (currently supports Skype) 40
ISR Swiss payment slip reference number 53
Logical Boolean value (true/false or yes/no) 1 (fix)
Memo Large text field 32767 (fix)
Multiple choice Selection list allowing multiple choices, e.g. used to assign 

several categories to an address
26

Normal character Standard text field 25
Normal character 
(multilingual)

Standard text field for 4 languages 200

Number Integer or decimal number 9/0
Number filled with 
zeros

Integer or decimal number of the form 0000000000 10/0

Picture Bitmap file -
Selection input When a value is entered, it is compared to a master table. 

If no match is found, a search form opens
-

Selection list The possible input values are selected from a master table 
generated previously

9 (fix)

Telephone number Telephone number excluding country and area code 20
Telephone/fax 
country code

Country code in the form “+99” -

Telephone/fax 
area code

Area code in the form “0999” -

Time Time in the form “hh:mm:ss” -
Uppercase char-
acter

Text field converted to all uppercase 20

Uppercase char-
acter (multilingual)

Text field converted to all uppercase for 4 languages 80

User selection Selection list containing the licensed users -

Adding/Editing Fields

- Select the table to modify and click on the register Fields.
- To add a new field press New.
- To edit a field either double-click on the field or click on the field and press Open.
- Enter a field designation (optionally for 4 languages).
- The “Internal field name” will be generated automatically.
- Select the “Field type”.
- Depending on the field type enter “Field length”, “Decimal places” and “Alignment” (for 

decimal numbers the field length includes the dot “.” and the decimal places).

Note:
Details on the setup of the various field types may be found in the Annex.

Form Layout



- On the Fields register press Layout
Important:
Adjust the window size to the minimum screen size of your users monitors before starting the lay-
out.

The layout contains two floating windows containing graphical elements and the fields which have 
not yet been placed on the form.

The layout always shows a single record input form. For notes tables there is a second register His-
tory allowing you to design the notes summary for the History register in Visual-Adress.

The form contains an invisible grid. All elements and fields will align to the nearest grid point outside 
of the upper left corner.

Graphical Elements:

- To place a graphical element on the form use drag-and-drop.

- To move the element hover over the element until  the cursor changes to  . Then click 
and drag the element.

- To size the element hover over the border until the cursor changes to  or . Then click 
and drag the border.

- To remove an element, click-and-drag it back to the floating window.
- Right-click an element to open the properties window. Here you can adjust the size, the col-

our, the type, the text alignment for an element title and add a title to the element.

Fields:

- To place a field on the form or inside a graphic element use drag-and-drop. Note that the 
field name will be inserted to the left of the field.

- To move either the field name or the field itself hover over the field until the cursor changes 
to .

- Sizing a field is identical to sizing a graphical element.
- Right-click a field to open its properties window.



- Select  No for “Input stop” if you don’t want the cursor to stop in that field when tabbing 
from one field to the next.

Element and Field Order:

- Go to menu Edit > Field Order Automatic…

- Select the order for area elements and fields and then press OK.

- To set the order manually go to menu Edit > Field Order Manual.
- Right-click the field and overwrite the “Input order” value.

History Layout for Notes:

This  form contains  some positioning help line to assist you in creating similar layouts  for  all  note 
types. Only add the main fields here, since the history is meant to locate notes quickly. Double-
clicking a note in Visual-Adress opens the single record form with all the information.

- Again, use drag-and-drop to insert new fields on the form. 
- Dragging the same field again inserts its name.

Indexes
Indexed fields help to speed up searching. Every field that you expect to search frequently should 
therefore be indexed.

When a new table is created, Visual-Admin automatically generates the primary (+ some other) in-
dexes. The primary index cannot be modified or deleted in the address table. It should not be mod-
ified or deleted in other tables.



Adding an Index:

- To add an index click on the Indexes register.
- If you want to allow only one occurrence of a value, activate “Unique index”.
- Select a field to add to the new index.
- Click the right arrow to add the field to the index.
- Select the sort order (ascending or descending).
- To build a combined index, add further fields.
- Press Save.

Editing an Index:

- You cannot edit an index. Instead first delete and then recreate it.

Deleting an Index:

- Select the index and press the Delete button or hit the [Delete] key.

Connection
Select the Connection register to connect notes to the address table.

- To connect the notes table to the address table either use the wizard

Or
- Select the field in the address table. Usually you will use the unique “Record-ID”.
- Select the corresponding field in the notes table. Usually you will use the “Address record ID”
- Select “Sorting Field 1”.
- Optionally select “Sorting Field 2”.



Security Profiles

Introduction
Here you define the user groups, who belongs to which user group(s) and function, table field and 
options profiles.

User Groups
- To add a new user group click on the  New icon go to Menu File > New User Group or hit 

[CTRL-N].
- Enter a designation and optionally a password.
- In the user list assign the members. A member may belong to several user groups.
- If “Can always view all data” in the user profile has been deactivated, you can activate 

“Can View Data” per user and user group. 

Function Profiles
You can define for each user group, which functions may be executed. “All functions” and “Stand-
ard” are predefined.



- To add a new function profile click on the New Icon, go to menu File > New Function Profile 
or hit [CTRL-N].

- Select the function profile.
- Activate or deactivate the execution permission.

Table Profiles
Define which functions may be executed on table level:

• Access to master data menu
• Read
• Add/insert (Enter)
• Edit
• Delete
• Access to note registers

- To add a new profile click on the New icon, go to menu File > New Table Profile or hit [CTRL-
N].

- Select the table profile.
- Activate or deactivate the execution permission.

Later assign these profiles to the user groups or users respectively.

Field Profiles
Define which functions may be executed on field level:

• Visible – field is displayed
• Modifiable – field may be edited
• Clienty – field has to be filled

The handling of this form is identical to the “Table Profiles”.

Option Profiles
Here you can define profiles which refer to the various registers in the menu “Tools > Options” in 
Visual-Adress.

If a user is not allowed to change the values of a register, he adopts the settings of the administrat-
or. The administrator settings are being used as a template for the other users.



User Profiles

Introduction
Here the user and password administration and authorisations for all Visual-Adress modules take 
place. All function, table, field and option profiles are assigned in this work area.

General
As long as there are unused licenses, new users may be added. If the maximum number of users is 
reached, a warning is issued. For additional users additional licenses would then have to be pur-
chased.

To add a new user

- Go to menu File > New User, click the New icon or hit [CTRL-N].
- Enter first name, surname, user ID (used for login), a password and an abbreviation (used to 

track user activities).
- Select a colour (used for quick identification in the calendar views).
- Select the dialogue language.
- Select the primary client of the user.

Sender
Enter address data of the user here.

Photo/Signature
Enter a photograph and a scanned signature here. Note that the type of picture file has to be pre-
defined in the General work area, register Settings.

User Groups
- Select the user group(s) to which the user belongs. 
- Unless “Can Always View All Data” is activated, select the user group(s) for which the user is 

allowed to see the data.

Authorisations
- Select applicable user group, function profile, table profile, field profile and options profile. 
- Press Save.



Annex: Fields Explained In Detail

Field Type General Selection Field Selection Filter Automatism Formula
Arithmetic Field Designation

(Internal field name)
Field length
Number of decimals
Alignment
Rounding

- - - Build a formula by 
calculating the 
field value from 
other fields us-
ing arithmetic 
functions

Date Designation
(Internal field name)
Alignment

- - Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Depending on 
selection

Designation
(Internal field name)
Field length
Number of decimals
Alignment

Use the wizard
Or
Select the data table (usu-

ally the pre-selected 
table)

Select the selection field
Select 1 or 2 fields to be 

displayed in the master 
table

Use the wizard
Or
Select the field which con-

tains the filter value
Select on which field the fil-

ter should be used

- -

E-mail address Designation
(Internal field name)
Field length
Alignment

- - Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Fax number Designation
(Internal field name)
Field length

- - Default country code
Default area code
(if not standard)

-

Internet address Designation
(Internal field name)
Field length
Alignment

- - Default value from a selec-
tion of system values or 
a manual input value

- for new record
for edited record

-



Field Type General Selection Field Selection Filter Automatism Formula
ISR (only used in Switzerland)
Logical Designation

(Internal field name)
Alignment

- - Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Memo Designation
(Internal field name)

- - Default value from a selec-
tion of system values or 
a manual input value

- for new record
Special: Updates a second 

field after input

-

Multiple choice Designation
(Internal field name)
Field length
Alignment

Use the wizard
Or
Select the data table (usu-

ally the pre-selected 
table)

Select the selection field
Select a code designation

- Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Normal charac-
ter

Designation
(Internal field name)
Field length

- - Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Normal charac-
ter (multilingual)

Designation in 4 languages
(Internal field name)
Field length

Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Number Designation
(Internal field name)
Field length
Decimal places
Alignment

Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Number filled 
with zeros

Designation
(Internal field name)
Field length

- - Default value from a selec-
tion of system values or 
a manual input value

-



Field Type General Selection Field Selection Filter Automatism Formula
Decimal places
Alignment

- for new record
- for edited record

Picture Designation
(Internal field name)

- - Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

Picture:
See below

Selection input
(displays a selec-
tion, when the in-
put is not found)

Designation
(Internal field name)

Select data table
Select field for input and 

testing

Use the wizard
Or
Select the field which con-

tains the filter value
Select on which field the fil-

ter should be used

Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Selection list
(always displays 
a selection)

Designation
(Internal field name)

Use the wizard
Or
Select the data table (usu-

ally the pre-selected 
table)

Select the selection field
Select 1 or 2 fields to be 

displayed in the master 
table

Use the wizard
Or
Select the field which con-

tains the filter value
Select on which field the fil-

ter should be used

Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Telephone num-
ber

Designation
(Internal field name)
Field length

- - Default country code
Default area code
(if not standard)

-

Telephone/fax 
country code

Designation
(Internal field name)
Field length

Use the wizard
Or
Select the data table (de-

fault “Addresses”)
Select the field in the data 

table (default “Ad-
dresses->Country”)

Select the display field (de-
fault “Countries->Coun-
try dialling code”)

Use the wizard
Or
Select the field which con-

tains the filter value
Select on which field the fil-

ter should be used

Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Telephone/fax 
prefix (area 

Designation
(Internal field name)

Use the wizard
Or

Use the wizard
Or

Default value from a selec-
tion of system values or 

-



Field Type General Selection Field Selection Filter Automatism Formula
code) Field length Select the data table (de-

fault “Addresses”)
Select the field in the data 

table (default “Ad-
dresses->ZIP”)

Select the display field (de-
fault “ZIP code master 
list->Area code”)

Select the field which con-
tains the filter value

Select on which field the fil-
ter should be used

a manual input value
- for new record
- for edited record

Time - - - Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Uppercase char-
acter

- - - Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

Uppercase char-
acter (multilin-
gual)

- - - Default value from a selec-
tion of system values or 
a manual input value

- for new record
- for edited record

-

User selection Designation
(Internal field name

- - Default user
- for new record
- for edited record

-

The “Picture” field uses the Formula register now named Picture. Here you can set various values to adjust the picture to the available space on the form.
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